What's new

No access to ClassicShaving.com!

I've been trying for a few days to access classicshaving.com and for some reason, IE keeps showing "Cannot find server." I don't see anyone else bringing this up so I must be the only one with this issue. I remember emailing the site's Admin and I was told no one else has brought it up to them. Why can't I access classicshaving.com when I used to do it all the time????? I've even purchased from the site before!!! :mad3: :confused1 :sad:

I have some firewall settings but I haven't changed them from when I could access the site before to now not being able to access the site. Any help would be greatly appreciated.

mrob said:
Works for me--are you Mac or PC?

I'm on a PC. I know what stuff I usually get from the site so I could just call in to make orders. But still, it is annoying. I like to browse the shaving selection, enjoy the thrill of seeing what I might buy.
Any problems with other websites?

Have you cleared your cache/deleted cookies?

Can you get to classicshaving.com with another browser such as Firefox?

Can you ping classicshaving.com?

Do you know how to run a traceroute?
Agent86 said:
Any problems with other websites?

Have you cleared your cache/deleted cookies?

Can you get to classicshaving.com with another browser such as Firefox?

Can you ping classicshaving.com?

Do you know how to run a traceroute?
Have you tried pinging ClassicShaving.com?
Use the tracert. It will probably be the most telling in finding the problem, if it is beyond your individual computer. - Justin
Have you looked at the Security Settings in Internet Exploder?

Maybe add Classic to the Allowed sites (permissions?) would help.

- Gramps
Thanks for all the suggestions. Sorry for not replying earlier.. I've been enjoying the holiday weekend. I've tried everything listed here. When I try to ping the site, it shows "Request timed out." I added the site to trusted sites in IE and that didn't work. I've cleared all cookies, temp files, and internet cache. I've tried tracert but after awhile, it says "request timed out." I saw website that suggest I set up a static IP address and that didn't work. I suppose it's just not meant to be.
I just tried Firefox and it still didn't work. I've even turned off my firewall and restarted my computer so I know it's not that. I've read that if your cable ISP changed the way they cached their DNS servers, it can affect a specific website. Oh well. I'm too lazy to call my ISP right now but if it gets annoying enough, I guess I will. Thanks for all the help.
I had a similar problem, exact same problem actually. Un-installing Google Web Accelerator (which I installed the day before I had problems) allowed me to get back on the site.

If you are getting request timed out, it is not your isp's dns. If you ever wonder about a resolution issue, go to a command prompt and type:
nslookup www.classicshaving.com

It will return the address. If it returns the wrong address or cannot find the address, then there is a problem.
E:\Documents and Settings\Scot>nslookup www.classicshaving.com
*** Can't find server name for address Non-existent domain
Server: UnKnown

Non-authoritative answer:
Name: www.classicshaving.com

That is what you should be getting, though you have to ignore the part on mine. I have a peculiar setup due to my vpn to the office.
Trader Joe has the right idea that something has probably been installed, but no real way to prove it.

You can also try a tracert
Tracing route to www.classicshaving.com []
over a maximum of 30 hops:

1 1 ms 1 ms 1 ms
2 9 ms 4 ms 5 ms
3 57 ms 6 ms 5 ms P4-0.LCR-01.WASHDC.verizon-gni.net [
4 9 ms 7 ms 7 ms so-6-0-0-0.ASH-PEER-RTR2.verizon-gni.net [130.81
5 6 ms 7 ms 7 ms 0.so-7-0-0.XL2.IAD8.ALTER.NET []
6 78 ms 77 ms 77 ms 0.so-3-3-0.XL2.SEA1.ALTER.NET []
7 101 ms 77 ms 77 ms POS5-0.XR2.SEA1.ALTER.NET []
8 171 ms 179 ms 174 ms 194.ATM7-0.GW3.SEA1.ALTER.NET []
9 212 ms 172 ms 213 ms accretive-gw.customer.alter.net []

10 222 ms 174 ms 180 ms OC48-POS6-0.van-dis-a.peer1.net []

Past that point it will probably just give you timeouts as the routers seem to drop icmp. I can still get to the site though, so I am guessing its something on your system.
Odd. I can't get in to it either, now. As of a week ago, it was fine.

ETA: Scratch that, it came up finally. But it didn't want to load the first time around.
I can't get in now either. Never had a problem till I read this post. Thanks alot for ruining it for me. Well at least you saved me some money, now I can't buy anything else in support of my habit. Now if only you can get all the other shaving gear sites to stop working!! :biggrin:
I've had some slow loading problems with their site recently. I've also noticed it go down on a few occasions in the past few days. Happens at both work and home.
Do you run a 3rd party privacy, ad-blocking, or spam-detection product (McAfee Internet Suite, Symantec Internet, Ad-Aware, etc.)? I had trouble with portions of B&B until I discovered McAfee was detecting large images as "ads!"

Looks like their servers may be getting hammered.

Server Error
The server encountered an internal error and was unable to complete your request.
Application server is busy. Either there are too many concurrent requests or the server still is starting up.

Edit. The Classic home page now has an update on their server issues.

Attention: Site Server is having difficulty due to upgrades. We aplogize for the inconvenience.
Top Bottom