• Hey Guest. We are currently doing lots and lots of work on the forum software. Please be patient while the kinks are worked out.

    Thanks!

Shick Injector stops shaving?

A week ago, I was trying to a get broken Personna adjustable injector to load properly. In the course of that, I loaded and reloaded lots of blades, including genuine new Schick Injector blades -- supposedly very good blades. Not NOS, new blades ordered online from dr*gstore.com.

I put one of these Schick blades into my model M injector that worked so well with lowly CVS store brand blades. I'm talking give-up-on-DE-shaving great shaves.

The shave was weird as heck. I tried a rare second stroke on my upper lip, this one ATG. Lots of stubble? Wow, the first WTG pass cleared no whiskers?? Huh?

My neck was equally unshaven.

Now this is not a defective razor. Is this a dull blade or one I damaged through handling? I though a damaged blade might hold nasty surprises in the other way -- like an old Feather.

I even checked to be sure I loaded the blade sharp-edge-facing-out. I had.

I finished up with a Tech loaded with a Surrey UK Gillette, which shaved fine.
 
The setup of the Injector doesn't exist. I removed the blade that wouldn't work. I'll try again tomorrow with a CVS blade.

Or do you mean a photo of the working Tech setup?
 
Top