What's new

Schick Injector: proper blade position

Hi, all:

My first post. I've caught the bug pretty bad, and already have four gillette DE's, a late 40's superspeed, "NEW" open comb, a Tech and Fat Boy. These seemed to be a fairly good representation of the Gillette camp, so I decided to branch out into Schick Injector territory. I won an older model on eBay, with the gold head and cream-colored bakelite handle.

My first shaves have been brutal, like I'm using one of those razor paint scrapers. Granted, I think I have to adjust technique, being used to DE, but I think the blade might be loaded incorrectly, on top of those little nubs, rather than behind. In the interest of full disclosure, they are Rite-Aid blades, and it could be I've got to dismantle the razor to clean it out more thoroughly.

Could an Injector user out there post a closeup picture, with blade loaded? Any help would be greatly appreaciated!

BTW, I've also picked up a couple of GEMs. Can't wait to rip my face up with them!
 
The injector cartridge should load the blade into razor so that the blades are behind those two bumps that are on either end of the face of the razor. They are hook shaped and help hold the blade in place. HTH

Mark
 
Based on your description, the blade is absolutely loaded wrong; don't know how that could happen. The front edge of the blade has to be behind and under the two nubs on the outer edges of the holder. I doubt you can push the blade back without damaging it, but will have to be careful when loading a new one. No wonder your face got carved up. Some of the older injectors can be a little more agressive than the newer ones, but for the most part they are a pretty mild razor and easy to find the correct angle; just keep the flat part of the head against your face, much like a GEM or Eveready. Don't use that one again until you can figure out why the blades aren't loading right.
 
Thanks for all the advice, and the pictures. I think I'll take it apart to clean it further, and will try some of the old schick blades that came with the razor, just to see if the Rite Aid blades are the problem. I was hesitant to use them, for some reason.

Of course, I had to use it again today as is, being a glutton for punishment! Back to my trusty Gillette NEW tomorrow, or perhaps a day of healing.
 
I doubt the blades are the problem. I've seen Injectors that had been used so much the nubs that hold the blades were worn down and held the blade at an angle. The far nub on the opposite side of the key tends to wear first.
 
That could very well be the problem. There was a lot of plating wear on it. I'll take a closer look at the nubs. It could be my problem will be solved by buying one of those cool-looking adjustable injectors on eBay for a small fortune....
 
What I did was to open up the head of the razor. I took a file and carefully filed down behind the nubs, and shaved down the surface where the blade sits. When I loaded the next blade, I used a small piece of wood to hold it back as I withdrew the key, and it stayed behind the nubs! I'll try shaving with it tomorrow, I think.

I'm recovering today, after my first shave with an open-comb GEM Micromatic, which gave me a very close shave, but a fair amount of razor burn on my neck. I'll get the technique down at some point.
 
Funny that, I just picked one up on eBay!

On the other one, which research shows is from the 40s (two patent #s), the filing job worked. I ended up with a terrific shave. However, in rinsing the razor off, i clunked it against the faucet, causing the blade to slide forward! Further modification may be necessary, I think.

Lucky it was cheap.
 
The E-type I picked up on eBay is in beautiful shape, though there's no case. the nubs were in perfect condition, and after soaking the head in clorox cleanup, brushing it clean with a little dish soap, and polishing it up with a little baking soda and water, it was ready to go. A more aggressive shave than the earlier razor (a type G), but a lot of fun to use.
 
Top