What's new

Razor Repair


Big Time update - I fixed it! Here's what I had to do, a spin off on what I did to get it to spin past 5 -

There is this little pin/tab thing, right at the indicator/clicker for the adjustment settings. Technically, its underneath the sleeve/cuff that you actually spin that has the numbers on it. When I was cleaning/drying my razor, I must have depressed the pin and that allowed the adjustment knob to spin past its maximum/minimum. It must be the locking mechanism...anyways it appears as if I spun it way under (or over) and the adjustment was way at the bottom of the threading, causing the razor to basically be longer! So I depressed the exposed pin with my fingernail, spun the adjuster, and spun it some more, until the razor started coming together and I breathed a sigh of relief :). Now it works like new again, really hard to adjust and locks well!


I am having a crisis! I think I may have somehow broken my Super Adjustable.

I was cleaning it out after my shave with a towel...and I noticed that the assembly below the head that has the 4 little pads that do the adjusting was moving up and down freely when the silo doors are open. Then when I closed it, I found it would only spin from 9-5. additionally, it seems as if there is no adjusting happening at all and the 4 pads seem flush with the razor head. I also noticed that when I close the silo doors, it no longer meets with resistance and then keeps tightening to lock - it just stops tightening after meeting risistance and doesnt lock! I am freaking out...:eek:

I shot a little video clip to help explain further...it is 22 megabytes, .mov format (all my camera makes)...I don't know really if I can compress it but I will try...I'll edit this post and add it as soon as I get it uploaded...

So can anybody help?:confused:
Hold ALT-DELETE-CTRL ... Wait, that won't work! :biggrin1:

Twist to open razor, set adjustment ring to 1, now close razor. I've had this happen too.. Good luck!
Forgot to update thread...I tried to do that but the adjustment ring won't go past 5. Only spun from 9-5, but then I looked closer and saw a little tab or something, in that little niche where the adjustment indicator/clicker thing is. I noticed that I could press it back into the handle, and I did that and it must have unlocked something because it allowed me to spin it to 1. so now it spins freely from 1-9 but still isnt doing any adjusting, doors still dont' lock securely, and adjustment assembly freely moves up and down when the doors are open. help!
Some of the early adjustables had a nut on the bottom thats what I thought might have worked loose. You could try soaking it in baby oil overnight might break free whats stuck.:mad:
Top Bottom